|SDHCI(4)||FreeBSD Kernel Interfaces Manual||SDHCI(4)|
NAMEsdhci — PCI SD Host Controller bridge driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following lines in loader.conf(5):
mmc_load="YES" mmcsd_load="YES" sdhci_load="YES"
DESCRIPTIONThe sdhci driver supports PCI devices with class 8 and subclass 5 according to SD Host Controller Specification. Driver supports up to six high speed 4bit MMC/SD slots per controller. Driver attaches mmc bus to the respective slot on card insertion and detaches it on card removing.
HARDWAREThe sdhci driver supports different specification compatible chips. The following chips have been verified to work:
- ENE CB712
- ENE CB714
- RICOH R5C822
- RICOH R5CE823
- TI PCIXX21/XX11
BUGSMany of existing SD controller chips have some nonstandard requirements, proprietary registers and hardware bugs, requiring additional handling. ENE chips are handled to work fine, while some revisions of RICOH and TI controllers still do not see cards without some additional initialization.
|February 9, 2012||FreeBSD|