|SCHED_ULE(4)||FreeBSD Kernel Interfaces Manual||SCHED_ULE(4)|
NAMEsched_ule — ULE scheduler
DESCRIPTIONThe sched_ule scheduler provides a number of advanced scheduler features not present in sched_4bsd(4), the traditional system scheduler. These features address SMP and interactivity and include:
- Thread CPU affinity.
- CPU topology awareness, including for hyper-threading.
- Per-CPU run queues.
- Interactivity heuristics that detect interactive applications and schedules them preferentially under high load.
The following sysctls are relevant to the operation of sched_ule:
- This read-only sysctl reports the name of the active scheduler.
- This read-write sysctl reports or sets the length of the quantum (in micro-seconds) granted to a thread.
HISTORYThe sched_ule scheduler first appeared in FreeBSD 5.1.
|August 10, 2012||FreeBSD|