|SBP_TARG(4)||FreeBSD Kernel Interfaces Manual||SBP_TARG(4)|
NAMEsbp_targ — Serial Bus Protocol 2 (SBP-2) Target Mode devices driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following lines in loader.conf(5):
firewire_load="YES" cam_load="YES" sbp_targ_load"YES"
DESCRIPTIONThe sbp_targ driver provides support for SBP-2 target mode. This driver is supposed to work with cam(4), targ(4) and firewire(4). You also need to use scsi_target(8), which can be found in /usr/share/examples/scsi_target, to provide actual devices.
# mdconfig -a -t malloc -s 10m md0 # scsi_target 0:0:0 /dev/md0 (Assuming sbp_targ0 on scbus0)
AUTHORSThe sbp_targ driver was written by .
BUGSThis driver is currently under development. It does not work correctly in multi-initiator environments or after the bus topology has been changed.
|November 7, 2003||FreeBSD|