|RUE(4)||FreeBSD Kernel Interfaces Manual||RUE(4)|
NAMErue — RealTek RTL8150 USB to Fast Ethernet controller driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe rue driver provides support for USB Ethernet adapters based on the RealTek RTL8150 USB to Fast Ethernet controller chip.
The RTL8150 contains an integrated Fast Ethernet MAC, which supports both 10 and 100Mbps speeds in either full or half duplex. Although designed to interface with 100Mbps peripheral, the existing USB standard specifies a maximum transfer speed of 12Mbps. Users should therefore not expect to actually achieve 100Mbps speeds with this device.
The rue driver supports the following media types:
- Enable auto selection of the media type and options. The user can manually override the auto selected mode by adding media options to the /etc/rc.conf file.
- Set 10Mbps operation. The mediaopt option can also be used to select either full-duplex or half-duplex modes.
- Set 100Mbps (Fast Ethernet) operation. The mediaopt option can also be used to select either full-duplex or half-duplex modes.
The rue driver supports the following media options:
- Force full duplex operation.
- Force half duplex operation.
For more information on configuring this device, see ifconfig(8).
HARDWAREThe rue driver supports RealTek RTL8150 based USB Ethernet adapters including:
- Buffalo (Melco Inc.) LUA-KTX
- Green House GH-USB100B
- LinkSys USB100M
- Billionton 10/100 FastEthernet USBKR2
- rue%d: watchdog timeout
- A packet was queued for transmission and a transmit command was issued, however the device failed to acknowledge the transmission before a timeout expired.
- rue%d: rx list init failed
- The driver failed to allocate an mbuf for the transmitter ring.
- rue%d: no memory for rx list
- The driver failed to allocate an mbuf for the receiver ring.
SEE ALSOarp(4), miibus(4), netintro(4), ng_ether(4), ifconfig(8)
RealTek RTL8150 data sheet, http://pdf.seekdatasheet.com/2008714/200807142333305235.pdf.
HISTORYThe rue device driver first appeared in FreeBSD 5.1.
AUTHORSThe rue driver was written by <akiyama@FreeBSD.org>.
|July 23, 2011||FreeBSD|