|HPTRR(4)||FreeBSD Kernel Interfaces Manual||HPTRR(4)|
NAMEhptrr — HighPoint RocketRAID device driver
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
The following tunables are settable from the loader:
DESCRIPTIONThe hptrr driver provides support for HighPoint's RocketRAID based RAID controllers.
These devices support SATA/ATA disk drives and provide RAID0 (striping), RAID1 (mirroring), and RAID5 functionality.
HARDWAREThe hptrr driver supports the following RAID controllers:
- RocketRAID 172x series
- RocketRAID 174x series
- RocketRAID 2210
- RocketRAID 222x series
- RocketRAID 2240
- RocketRAID 230x series
- RocketRAID 231x series
- RocketRAID 232x series
- RocketRAID 2340
- RocketRAID 2522
NOTESThe hptrr driver only works on the i386 and amd64 platforms as it requires a binary blob object from the manufacturer which they only supply for these platforms. The hptrr driver does not work on i386 with pae(4) enabled.
This driver does not support the RR182x series controller. See the hptmv(4) manual page for details on support.
This driver supersedes the older rr232x driver.
HISTORYThe hptrr device driver first appeared in FreeBSD 6.3.
AUTHORSThe hptrr device driver was written by , and ported to FreeBSD by . This manual page was written by .
BUGSThe hptrr driver does not support manipulating the RAID from the OS, RAIDs need to be set up from the on-board BIOS.
|June 6, 2012||FreeBSD|