|RGEPHY(4)||FreeBSD Kernel Interfaces Manual||RGEPHY(4)|
NAMErgephy — RealTek RTL8168/8169/8110/8211 series 10/100/1000 Gigabit Ethernet PHY driver
SYNOPSISTo compile all available PHY drivers into the kernel, place the following line in your kernel configuration file:
Alternatively, to selectively compile this driver into the kernel, place the following lines in your kernel configuration file instead:
DESCRIPTIONThe rgephy driver supports the RealTek RTL8168, RTL8169, RTL8110 and RTL8211 series integrated 10/100/1000 Gigabit Ethernet PHYs.
In order to get a list of media types and options supported by a specific instance of the rgephy driver, run
ifconfig -m on the instance of its parent MAC driver.
Additionally, the rgephy driver supports the following special media option:
- When manually setting media type and options via ifconfig(8), the rgephy driver by default also triggers an autonegotiation advertising the selected media. This is done in order to work around hardware issues in certain scenarios. It is believed that this behavior does not cause harm in general but in fact can have an adverse effect in edge cases. In order to manually set the media type and options without also triggering an autonegotiation, the rgephy driver allows to turn this behavior off via the flag0 media option.
Note that this special media option will not show up in the output of ifconfig(8), even when set.
EXAMPLESManually set 100BASE-TX full-duplex without also triggering an autonegotiation:
ifconfig re0 media 100baseTX mediaopt full-duplex,flag0
|January 16, 2011||FreeBSD|