|NXGE(4)||FreeBSD Kernel Interfaces Manual||NXGE(4)|
NAMEnxge — Neterion Xframe 10GbE Server/Storage adapter driver
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe nxge driver provides support for Neterion Xframe-I and Xframe-II adapters. The driver supports TCP Segmentation Offload (TSO/LSO), Large Receive Offload (LRO), Jumbo Frames (5 buffer mode), Header Separation (Rx 2 buffer mode), VLAN, and Promiscuous mode.
For general information and support, please visit the Neterion support page http://www.neterion.com/support/support.html.
Support for Jumbo Frames is provided via the interface MTU setting. Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility configures the adapter to transmit and receive Jumbo Frames. Xframe adapters support Jumbo Frames up to 9600 bytes.
For Jumbo Frames, the driver will try to allocate physically contiguous buffers. Failures to do so may degrade the performance. To resolve such problems, please visit http://www.neterion.com where additional information and a kernel patch can be found.
For more information on configuring this device, see ifconfig(8).
HARDWAREThe nxge driver supports Neterion Xframe 10 Gigabit Ethernet adapters listed in http://www.neterion.com/how/pricing.html.
SUPPORTFor troubleshooting tips and FAQs, please visit http://trac.neterion.com/cgi-bin/trac.cgi/wiki/TitleIndex?anonymous.
For any issues please send an email to <email@example.com>.
HISTORYThe nxge device driver first appeared in FreeBSD 7.0.
AUTHORSThe nxge driver was written by <firstname.lastname@example.org>.
|October 16, 2007||FreeBSD|