|NVRAM(4)||FreeBSD Kernel Interfaces Manual||NVRAM(4)|
NAMEnvram — non-volatile RAM
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe nvram driver provides access to BIOS configuration NVRAM on i386 and amd64 systems.
PC motherboard uses a small non-volatile memory to store BIOS settings which is usually part of its clock chip and sometimes referred as “CMOS SRAM”. This driver exposes bytes 14 through 128 of the NVRAM, or a total of 114 bytes, at offset zero of the device file /dev/nvram.
This driver is useful for cloning machines that shares the same hardware configuration and need same BIOS setting tweaks.
IMPLEMENTATION NOTESThe BIOS NVRAM's bytes 16 through 31 are checksummed at byte 32. This driver does not take care for these checksums.
EXAMPLESBackup existing BIOS NVRAM to nvram.bin:
dd if=/dev/nvram of=nvram.bin
Restore BIOS NVRAM from nvram.bin:
dd if=nvram.bin of=/dev/nvram
HISTORYThe nvram device driver first appeared in FreeBSD 6.4.
AUTHORSThe nvram device driver was written by . This manual page was written by .
|February 8, 2010||FreeBSD|