|NVD(4)||FreeBSD Kernel Interfaces Manual||NVD(4)|
NAMEnvd — NVM Express disk driver
SYNOPSISTo compile this driver into your kernel, place the following lines in your kernel configuration file:
Or, to load the driver as a module at boot, place the following lines in loader.conf(5):
DESCRIPTIONThe nvd driver exposes NVM Express (NVMe) namespaces as disks to the kernel disk storage API. It depends on the nvme(4) driver for notification of existing NVMe namespaces and submission of NVM I/O commands.
Device nodes from the nvd driver will have the format /dev/nvdX and are GEOM(4) disks which can be partitioned by geom(8). Note that device nodes from the nvme(4) driver are not GEOM(4) disks and cannot be partitioned.
HISTORYThe nvd driver first appeared in FreeBSD 9.2.
AUTHORSThe nvd driver was developed by Intel and originally written by <jimharris@FreeBSD.org>, with contributions from Joe Golio at EMC.
This man page was written by<jimharris@FreeBSD.org>.
|March 18, 2014||FreeBSD|