|NMDM(4)||FreeBSD Kernel Interfaces Manual||NMDM(4)|
NAMEnmdm — nullmodem terminal driver
DESCRIPTIONThe nmdm driver provides two tty(4) devices connected by a virtual “null modem” cable.
If either of the two tty devices have the CDSR_OFLOW bit (“
stty dsrflow”) set in their line discipline, the nmdm device will emulate the speed configured in the termios(4) settings. The speed emulation works independently in the two directions, controlled by the slower end's termios settings ( c_ispeed, c_ospeed, CS5 ... CS8, CSTOPB and PARENB).
- /dev/nmdm N[ AB]
- nullmodem device nodes. Where the A node has a matching B node.
The nmdm driver implements “on-demand device creation” so simply accessing a given instance in /dev will create it.
HISTORYThe nmdm driver first appeared in FreeBSD 4.4.
|January 27, 2005||FreeBSD|