|MPT(4)||FreeBSD Kernel Interfaces Manual||MPT(4)|
NAMEmpt — LSI Fusion-MPT SCSI/Fibre Channel driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe mpt driver provides support for the LSI Logic Fusion-MPT family of SCSI, Fibre Channel and SAS controllers.
HARDWAREThe following controllers are supported by the mpt driver:
- LSI Logic 53c1030, LSI Logic LSI2x320-X (Single and Dual Ultra320 SCSI)
- LSI Logic AS1064, LSI Logic AS1068 (SAS/SATA)
- LSI Logic FC909 (1Gb/s Fibre Channel)
- LSI Logic FC909A (Dual 1Gb/s Fibre Channel)
- LSI Logic FC919, LSI Logic 7102XP-LC (Single 2Gb/s Fibre Channel)
- LSI Logic FC929, LSI Logic FC929X, LSI Logic 7202XP-LC (Dual 2Gb/s Fibre Channel)
- LSI Logic FC949X (Dual 4Gb/s Fibre Channel)
- LSI Logic FC949E, LSI Logic FC949ES (Dual 4Gb/s Fibre Channel PCI-Express)
The Ultra 320 SCSI controller chips supported by the mpt driver can be found onboard on many systems including:
- Dell PowerEdge 1750 thru 2850
- IBM eServer xSeries 335
These systems also contain Integrated RAID Mirroring and Integrated RAID Mirroring Enhanced which this driver also supports.
The SAS controller chips are also present on many new AMD/Opteron based systems, like the Sun 4100. Note that this controller can drive both SAS and SATA drives or a mix of them at the same time. The Integrated RAID Mirroring available for these controllers is poorly supported at best.
The Fibre Channel controller chipset are supported by a broad variety of speeds and systems. The Apple Fibre Channel HBA is in fact the FC949ES card.
This driver also supports target mode for Fibre Channel cards. This support may be enabled by setting the desired role of the core via the LSI Logic firmware utility that establishes what roles the card can take on - no separate compilation is required.
SEE ALSOcd(4), ch(4), da(4), mps(4), pci(4), sa(4), scsi(4), targ(4), mptutil(8), gmultipath(8)
LSI Logic Website, http://www.lsi.com/.
HISTORYThe mpt driver first appeared in FreeBSD 4.6.
AUTHORSThe mpt driver was originally written for FreeBSD by and marginally improved upon by <mjacob@FreeBSD.org>.
<gibbs@FreeBSD.org> and <scottl@FreeBSD.org> have made more substantial improvements.
|July 23, 2011||FreeBSD|