|MOS(4)||FreeBSD Kernel Interfaces Manual||MOS(4)|
NAMEmos — Moschip MCS7730/MCS7830/MCS7832 USB Ethernet driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe mos driver provides support for USB Ethernet adapters based on the Moschip MCS7730/MCS7830/MCS7832 chipset.
The adapters that contain the Moschip MCS7730/MCS7830/MCS7832 chipset will operate at 100Base-TX and full-duplex.
The Moschip contains a 10/100 Ethernet MAC with MII interface and is designed to work with both Ethernet and HomePNA transceivers. Although designed to interface with 100Mbps peripherals, this only works with USB 2.0. The existing USB 1.0 standard specifies a maximum transfer speed of 12Mbps. USB 1.0 Users should therefore not expect to actually achieve 100Mbps speeds with these devices.
The Moschip supports a 64-bit multicast hash table, single perfect filter entry for the station address and promiscuous mode. Packets are received and transmitted over separate USB bulk transfer endpoints.
For more information on configuring this device, see ifconfig(8).
HARDWAREAdapters supported by the mos driver include:
- Sitecom LN030
SEE ALSOaltq(4), arp(4), miibus(4), netintro(4), ng_ether(4), ifconfig(8)
ADMtek AN986 data sheet, http://www.moschip.com/data/products/MCS7830/Data%20Sheet_7830.pdf.
HISTORYThe mos device driver first appeared in FreeBSD 8.2.
AUTHORSThe mos driver was written by .
|February 14, 2011||FreeBSD|