|MFI(4)||FreeBSD Kernel Interfaces Manual||MFI(4)|
NAMEmfi — LSI MegaRAID SAS driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThis driver is for LSI's next generation PCI Express SAS RAID controllers. Access to RAID arrays (logical disks) from this driver is provided via /dev/mfid? device nodes. A simple management interface is also provided on a per-controller basis via the /dev/mfi? device node.
The mfi name is derived from the phrase "MegaRAID Firmware Interface", which is substantially different than the old "MegaRAID" interface and thus requires a new driver. Older SCSI and SATA MegaRAID cards are supported by amr(4) and will not work with this driver.
Two sysctls are provided to tune the mfi driver's behavior when a request is made to remove a mounted volume. By default the driver will disallow any requests to remove a mounted volume. If the sysctl dev.mfi.%d.delete_busy_volumes is set to 1, then the driver will allow mounted volumes to be removed.
A tunable is provided to adjust the mfi driver's behaviour when attaching to a card. By default the driver will attach to all known cards with high probe priority. If the tunable hw.mfi.mrsas_enable is set to 1, then the driver will reduce its probe priority to allow mrsas to attach to the card instead of mfi.
HARDWAREThe mfi driver supports the following hardware:
- LSI MegaRAID SAS 1078
- LSI MegaRAID SAS 8408E
- LSI MegaRAID SAS 8480E
- LSI MegaRAID SAS 9240
- LSI MegaRAID SAS 9260
- Dell PERC5
- Dell PERC6
- IBM ServeRAID M1015 SAS/SATA
- IBM ServeRAID M1115 SAS/SATA
- IBM ServeRAID M5015 SAS/SATA
- IBM ServeRAID M5110 SAS/SATA
- IBM ServeRAID-MR10i
- Intel RAID Controller SRCSAS18E
- Intel RAID Controller SROMBSAS18E
- array/logical disk interface
- management interface
- mfid%d: Unable to delete busy device
- An attempt was made to remove a mounted volume.
HISTORYThe mfi driver first appeared in FreeBSD 6.1.
AUTHORSThe mfi driver and this manual page were written by <scottl@FreeBSD.org>.
BUGSThe driver does not support big-endian architectures at this time.
|July 15, 2013||FreeBSD|