|OFW_CONSOLE(4)||FreeBSD Kernel Interfaces Manual (SPARC64)||OFW_CONSOLE(4)|
NAMEofw_console — Open Firmware console
DESCRIPTIONThe ofw_console driver provides a simple text console, using the Open Firmware services for input and output. It will use the Open Firmware console devices set via the input-device and output-device variables.
This driver is deprecated and only provided as a fallback console mechanism if the real console hardware can not be driven by FreeBSD.
In case the ofw_console console appears to work too slowly, its responsiveness probably can be improved by including options OFWCONS_POLL_HZ=N. When omitted, OFWCONS_POLL_HZ defaults to 4. For example, on Sun Ultra 2 a value of 20 or higher works best. Too high values, on the other hand, can cause ofw_console to unnecessarily consume CPU.
- terminal input device in case the console input device is the keyboard
- terminal output device in case the console output device is the screen
- terminal device in case both the console input and output device is tty[a-z]
HISTORYThe ofw_console driver first appeared in FreeBSD 5.0.
AUTHORSThe ofw_console driver was written by <benno@FreeBSD.org>.
CAVEATSSince the Open Firmware will handle BREAK (or Stop-A) sequences before ofw_console, the preferred way to enter ddb(4) when using ofw_console is to include options ALT_BREAK_TO_DEBUGGER in a ddb-enabled kernel, and enter the alternate BREAK sequence (RETURN TILDE CTRL-b).
BUGSThe ofw_console driver is not a real tty(4) driver and is not MPSAFE. The ofw_console driver also does not attach to the hardware resources it actually talks to. Therefore it cannot be included in the kernel together with real console hardware drivers like creator(4), machfb(4) and uart(4).
|June 18, 2005||FreeBSD|