|AMS(4)||FreeBSD Kernel Interfaces Manual||AMS(4)|
NAMEams — ADB Mouse Driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
DESCRIPTIONThe ams driver provides support for mice and trackpads attached to the Apple Desktop Bus (ADB) implementing both the base and extended ADB mouse protocols.
HARDWAREDevices supported by the ams driver include:
- Apple Mouse
- ADB Extended Mouse
- MacAlly 2-Button Mouse
- Apple iBook Trackpad
- Apple PowerBook Trackpad
- On ADB trackpads, setting this sysctl to 1 causes taps on the trackpad to be interpreted as button clicks.
SEE ALSOApple Tech Note HW01: ADB - The Untold Story: Space Aliens Ate My Mouse: http://developer.apple.com/legacy/mac/library/technotes/hw/hw_01.html
HISTORYThe ams device driver appeared in FreeBSD 8.0.
AUTHORSThe ams driver was written by <nwhitehorn@FreeBSD.org>.
|December 3, 2009||FreeBSD|