|AKBD(4)||FreeBSD Kernel Interfaces Manual||AKBD(4)|
NAMEakbd — ADB Keyboard Driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
DESCRIPTIONThe akbd driver provides support for all keyboards attached to the Apple Desktop Bus (ADB).
HARDWAREDevices supported by the akbd driver include:
- Apple Extended Keyboard
- Apple Keyboard II
- Apple iBook Keyboard
- Apple PowerBook Keyboard
EVENTSThe akbd driver sends events to devd(8) for the following events under the PMU system:
- Power button - Button subsystem, pressed type.
SYSCTL VARIABLESThe akbd driver supports the following sysctl variable for configuring the Fn keys:
- Set the Fn keys to be their F-key type as default. A value of 0 causes the F-keys keys to work as special keys by default ( abtn(4)) and a value of 1 sets them to behave as F-keys by default.
HISTORYThe akbd device driver appeared in FreeBSD 8.0.
AUTHORSThe akbd driver was written by <nwhitehorn@FreeBSD.org>.
|December 3, 2009||FreeBSD|