|PERFMON(4)||FreeBSD Kernel Interfaces Manual (i386)||PERFMON(4)|
NAMEperfmon — CPU performance-monitoring interface
DESCRIPTIONThe perfmon driver provides access to the internal performance-monitoring capabilities of the Intel Pentium and Pentium Pro CPUs. These processors implement two internal counters which can be configured to measure a variety of events for either count or duration (in CPU cycles), as well as a cycle counter which counts clock cycles. The perfmon driver provides a device-style interface to these capabilities.
All access to the performance-monitoring counters is performed through the special device file “ /dev/perfmon”. This device supports a number of ioctl(2) requests, defined in < machine/perfmon.h> along with the definitions of the various counters for both Pentium and Pentium Pro processors.
NOTA BENE: The set of available events differs from processor to processor. It is the responsibility of the programmer to ensure that the event numbers used are the correct ones for the CPU type being measured.
The following ioctl(2) requests are defined:
struct pmc) Set up a counter with parameters and flags defined in the structure. The following fields are defined in
- the number of the counter in question; must be less than NPMC (currently 2).
- the particular event number to be monitored, as defined in < machine/perfmon.h>.
- the unit mask value, specific to the event type (see the Intel documentation).
- flags modifying the operation of the counter (see below).
- the counter mask value; essentially, this is a threshold used to restrict the count to events lasting more (or less) than the specified number of clocks.
pmc_flagsvalues are defined:
- count events in user mode
- count events in kernel mode
- count number of events rather than their duration
- invert the sense of the counter mask comparison
struct pmc) returns the current configuration of the specified counter.
int) starts (stops) the specified counter. Due to hardware deficiencies, counters must be started and stopped in numerical order. (That is to say, counter 0 can never be stopped without first stopping counter 1.) The driver will not enforce this restriction (since it may not be present in future CPUs).
int) reset the specified counter to zero. The counter should be stopped with PMIOSTOP before it is reset. All counters are automatically reset by PMIOSETUP.
struct pmc_data) get the current value of the counter. The
pmc_datastructure defines two fields:
- the number of the counter to read
- the resulting value as a 64-bit signed integer
In the future, it may be possible to use the
RDPMCinstruction on Pentium Pro processors to read the counters directly.
struct pmc_tstamp) read the time stamp counter. The
pmc_tstampstructure defines two fields:
- the approximate rate of the counter, in MHz
- the current value of the counter as a 64-bit integer
It is important to note that the counter rate, as provided in the
pmct_ratefield, is often incorrect because of calibration difficulties and non-integral clock rates. This field should be considered more of a hint or sanity-check than an actual representation of the rate of clock ticks.
- character device interface to counters
- include file with definitions of structures and event types
- sample source code demonstrating use of all the ioctl() commands
SEE ALSOioctl(2), hwpmc(4)
Intel Corporation, Pentium Pro Family Developer's Manual, vol. 3, January 1996, Operating System Writer's Manual.
HISTORYThe perfmon device first appeared in FreeBSD 2.2.
AUTHORSThe perfmon driver was written by , MIT Laboratory for Computer Science.
|March 26, 1996||FreeBSD|