|EX(4)||FreeBSD Kernel Interfaces Manual (i386)||EX(4)|
NAMEex — Ethernet device driver for the Intel EtherExpress Pro/10 and Pro/10+
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe ex driver provides support for Ethernet adapters based on the Intel i82595 chip.
On the ISA bus, the card will be searched for in the I/O address range 0x200 - 0x3a0. The IRQ will be read from the EEPROM on the card. For correct operation Plug-N-Play support should be disabled.
On the PC Card bus, the card will be automatically recognized and configured.
HARDWAREThe ex driver supports the following Ethernet adapters:
- Intel EtherExpress Pro/10 ISA
- Intel EtherExpress Pro/10+ ISA
- Olicom OC2220 Ethernet PC Card
- Olicom OC2232 Ethernet/Modem PC Card
- Silicom Ethernet LAN PC Card
- Silicom EtherSerial LAN PC Card
- ex%d: Intel EtherExpress Pro/10, address %6D, connector %s
- The device probe found an installed card, and was able to correctly install the device driver.
- ex%d: WARNING: board's EEPROM is configured for IRQ %d, using %d
- The device probe detected that the board is configured for a different interrupt than the one specified in the kernel configuration file.
- ex%d: invalid IRQ.
- The device probe detected an invalid IRQ setting.
HISTORYThe ex device driver first appeared in FreeBSD 2.2.
AUTHORSThe ex device driver was written by . The PC Card attachment was written by and . This manual page was written by .
BUGSCurrently the driver does not support multicast.
The Silicom EtherSerial card's serial port does not currently work. The Olicom OC2232 PC Card should work with the ex driver, but is currently completely broken.
|July 16, 2005||FreeBSD|