|MAC_STUB(4)||FreeBSD Kernel Interfaces Manual||MAC_STUB(4)|
NAMEmac_stub — MAC policy stub module
SYNOPSISTo compile the stub policy into your kernel, place the following lines in your kernel configuration file:
Alternately, to load the stub module at boot time, place the following line in your kernel configuration file:
and in loader.conf(5):
DESCRIPTIONThe mac_stub policy module implements a stub MAC policy that has no effect on access control in the system. Unlike mac_none(4), each MAC entry point is defined as a “no-op”, so the policy module will be entered for each event, but no change in system behavior should result.
Label FormatNo labels are defined for mac_stub.
SEE ALSOmac(4), mac_biba(4), mac_bsdextended(4), mac_ifoff(4), mac_lomac(4), mac_mls(4), mac_none(4), mac_partition(4), mac_portacl(4), mac_seeotheruids(4), mac_test(4), mac(9)
HISTORYThe mac_stub policy module first appeared in FreeBSD 5.1 and was developed by the TrustedBSD Project.
AUTHORSThis software was contributed to the FreeBSD Project by Network Associates Labs, the Security Research Division of Network Associates Inc. under DARPA/SPAWAR contract N66001-01-C-8035 (“CBOSS”), as part of the DARPA CHATS research program.
BUGSSee mac(9) concerning appropriateness for production use. The TrustedBSD MAC Framework is considered experimental in FreeBSD.
While the MAC Framework design is intended to support the containment of the root user, not all attack channels are currently protected by entry point checks. As such, MAC Framework policies should not be relied on, in isolation, to protect against a malicious privileged user.
|December 1, 2002||FreeBSD|