|KBDMUX(4)||FreeBSD Kernel Interfaces Manual||KBDMUX(4)|
NAMEkbdmux — keyboard multiplexer
DESCRIPTIONThe kbdmux keyboard driver provides support for basic keyboard multiplexing. It is built around the idea of a “super keyboard”. The kbdmux driver acts as a master keyboard consuming input from all slave keyboards attached to it.
Slave keyboards can be attached to or detached from the kbdmux keyboard driver with the kbdcontrol(1) utility.
HISTORYThe kbdmux module was implemented in FreeBSD 6.0.
CAVEATSThe kbdmux keyboard driver switches all slave keyboards into K_RAW mode. Thus all slave keyboards attached to the kbdmux keyboard share the same state. The kbdmux keyboard is logically equivalent to one keyboard with lots of duplicated keys.
|July 12, 2005||FreeBSD|