|ISP(4)||FreeBSD Kernel Interfaces Manual||ISP(4)|
NAMEisp — Qlogic based SCSI and FibreChannel SCSI Host Adapters
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThis driver provides access to SCSI or FibreChannel devices.
SCSI features include support for Ultra SCSI and wide mode transactions for SCSI, Ultra2 LVD (for the ISP1080 and ISP1280), and Ultra3 LVD (for the ISP12160).
Fibre Channel support uses FCP SCSI profile for FibreChannel, and utilizes Class 3 and Class 2 connections (Qlogic 2100 is Class 3 only, minor patches to the Qlogic 2200 to force Class 2 mode). Support is available for Public and Private loops, and for point-to-point connections (Qlogic 2200 only). The newer 2-Gigabit cards (2300, 2312, 2322) and 4-Gigabit (2422, 2432) are also supported. Command tagging is supported for all (in fact, FibreChannel requires tagging). Fabric support is enabled by default for other than 2100 cards. Fabric support for 2100 cards has been so problematic and these cards are so old now that it is just not worth your time to try it.
FIRMWAREFirmware is available if the ispfw(4) module is loaded during bootstrap (q.v.).
It is strongly recommended that you use the firmware available from ispfw(4) as it is the most likely to have been tested with this driver.
HARDWARECards supported by the isp driver include:
- SBus Fast Wide, Ultra Fast Wide cards, Single Ended or Differential cards.
- Qlogic 1020 Fast Wide and Differential Fast Wide PCI cards.
- Qlogic 1040 Ultra Wide and Differential Ultra Wide PCI cards. Also known as the DEC KZPBA-CA (single ended) and KZPBA-CB (HVD differential).
- Qlogic 1240
- Qlogic 1240 Dual Bus Ultra Wide and Differential Ultra Wide PCI cards.
- Qlogic 1020
- Qlogic 1020 SCSI cards.
- Qlogic 1040
- Qlogic 1040 Ultra SCSI cards.
- Qlogic 1080
- Qlogic 1280 LVD Ultra2 Wide PCI cards.
- Qlogic 1280
- Qlogic 1280 Dual Bus LVD Ultra2 Wide PCI cards.
- Qlogic 12160
- Qlogic 12160 Dual Bus LVD Ultra3 Wide PCI cards.
- Qlogic 210X
- Qlogic 2100 and 2100A Copper and Optical Fibre Channel Arbitrated Loop (single, dual).
- Qlogic 220X
- Qlogic 2200 Copper and Optical Fibre Channel Arbitrated Loop PCI cards (single, dual, quad).
- Qlogic 2300
- Qlogic 2300 Optical Fibre Channel PCI cards.
- Qlogic 2312
- Qlogic 2312 Optical Fibre Channel PCI cards.
- Qlogic 234X
- Qlogic 234X Optical Fibre Channel PCI cards (2312 chipset, single and dual attach).
- Qlogic 2322
- Qlogic 2322 Optical Fibre Channel PCIe cards.
- Qlogic 200
- Dell Branded version of the QLogic 2312 Fibre Channel PCI cards.
- Qlogic 2422
- Qlogic 2422 Optical Fibre Channel PCI cards (4 Gigabit)
- Qlogic 2432
- Qlogic 2432 Optical Fibre Channel PCIe cards (4 Gigabit)
CONFIGURATION OPTIONSTarget mode support may be enabled with the
BOOT OPTIONSThe following options are switchable by setting values in /boot/device.hints.
- A hint value to disable driver in kernel.
- A hint value to disable loading of firmware ispfw(4).
- A hint value to use PCI memory space instead of I/O space access for.
- A hint value to use PCI I/O space instead of Memory space access for.
- A hint value to ignore board NVRAM settings for. Otherwise use NVRAM settings.
- A hint value to set full duplex mode.
A hint value to select topology of connection. Supported values are:
- Prefer loopback and fallback to point to point.
- Prefer point to point and fallback to loopback.
- Loopback only.
- Point to point only.
- This should be the full 64 bit World Wide Port Name you would like to use, overriding the value in NVRAM for the card.
- This should be the full 64 bit World Wide Node Name you would like to use, overriding the value in NVRAM for the card.
- A hint to override or set the Initiator ID or Loop ID. For Fibre Channel cards in Local Loop topologies it is strongly recommended that you set this value to non-zero.
- A hint to define default role for isp instance (target, initiator, both).
- A hint value for a driver debug level (see the file /usr/src/sys/dev/isp/ispvar.h for the values.
- This value says how long to wait in seconds after loop has gone down before giving up and expiring all of the devices that were visible. The default is 300 seconds (5 minutes). A separate (nonadjustable) timeout is used when booting to not stop booting on lack of FC connectivity.
- This value says how long to wait for devices to reappear if they (temporarily) disappear due to loop or fabric events. While this timeout is running, I/O to those devices will simply be held.
- This is the readonly World Wide Node Name value for this port.
- This is the readonly World Wide Port Name value for this port.
AUTHORSThe isp driver was written by Matthew Jacob originally for NetBSD at NASA/Ames Research Center.
BUGSThe driver currently ignores some NVRAM settings.
Target mode support is not completely reliable yet. It works reasonably well for Fibre Channel, somewhat well for Qlogic 1040 cards, but does not yet work for the other cards (due to last minute unannounced changes in firmware interfaces).
|February 28, 2007||FreeBSD|