|ISCSI(4)||FreeBSD Kernel Interfaces Manual||ISCSI(4)|
NAMEiscsi — iSCSI initiator
SYNOPSISTo compile this driver into the kernel, place the following line in the kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe iscsi subsystem provides the kernel component of an iSCSI initiator. The initiator is the iSCSI client, which connects to an iSCSI target, providing local access to a remote block device. The userland component is provided by iscsid(8) and both the kernel and userland are configured using iscsictl(8). The iscsi subsystem is responsible for implementing the “Full Feature Phase” of the iSCSI protocol.
SYSCTL VARIABLESThe following variables are available as both sysctl(8) variables and loader(8) tunables:
- The number of seconds to wait for the target to respond to a NOP-Out PDU. In the event that there is no response within that time the session gets forcibly restarted.
- The number of seconds to wait for ctld(8) to establish a session. After that time iscsi will abort and retry.
- The number of seconds to wait for a login attempt to succeed. After that time iscsi will abort and retry.
- The maximum number of outstanding IO requests.
- Controls the behavior after an iSCSI connection has been dropped due to network problems. When set to 1, a dropped connection causes the iSCSI device nodes to be destroyed. After reconnecting, they will be created again. By default, the device nodes are left intact. While the connection is down all input/output operations are suspended, to be retried after the connection is reestablished.
HISTORYThe iscsi subsystem first appeared in FreeBSD 10.0.
AUTHORSThe iscsi subsystem was developed by < trasz@FreeBSD.org> under sponsorship from the FreeBSD Foundation.
|September 11, 2014||FreeBSD|