|VXGE(4)||FreeBSD Kernel Interfaces Manual||VXGE(4)|
NAMEvxge — Neterion X3100 10GbE Server/Storage adapter driver
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe vxge driver provides support for Neterion X3100 adapters. The driver supports TCP Segmentation Offload (TSO/LSO), Large Receive Offload (LRO), Jumbo Frames, Receive Traffic Hash (RTH), VLAN, Promiscuous mode and Multi function mode.
The vxge driver supports the following function modes:
For general information and support, please visit the Neterion support page http://www.neterion.com/support/support.html.
Support for Jumbo Frames is provided via the interface MTU setting. Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility configures the adapter to transmit and receive Jumbo Frames. X3100 adapters support Jumbo Frames up to 9600 bytes.
For Jumbo Frames, the driver will try to allocate physically contiguous buffers. Failures to do so may degrade the performance. To resolve such problems, please visit http://www.neterion.com where additional information and a kernel patch can be found.
For more information on configuring this device, see ifconfig(8).
HARDWAREThe vxge driver supports Neterion X3100 10 Gigabit Ethernet adapters listed in http://www.neterion.com.
SUPPORTFor troubleshooting tips and FAQs, please visit http://trac.neterion.com/cgi-bin/trac.cgi/wiki/TitleIndex?anonymous.
For any issues please send an email to <firstname.lastname@example.org>.
AUTHORSThe vxge driver was written by <email@example.com>.
|March 16, 2011||FreeBSD|