|FWIP(4)||FreeBSD Kernel Interfaces Manual||FWIP(4)|
NAMEfwip — IP over FireWire driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following lines in loader.conf(5):
DESCRIPTIONThe fwip driver provides standard IP over FireWire (IEEE 1394) based on the protocols described in RFC 2734 and RFC 3146.
This driver supports polling(4) as well if it is compiled with the DEVICE_POLLING option.
SEE ALSOarp(4), firewire(4), fwe(4), fwohci(4), netintro(4), polling(4), ifconfig(8), kldload(8), sysctl(8)
HISTORYThe fwip device driver first appeared in FreeBSD 5.3.
AUTHORSThe fwip driver and this manual page were written by , based on earlier work by .
BUGSThis driver currently does not support the MCAP protocol for multicast IP over FireWire. Multicast packets are treated as broadcast packets which is sufficient for most trivial uses of multicast.
|July 16, 2005||FreeBSD|