|BWI(4)||FreeBSD Kernel Interfaces Manual||BWI(4)|
NAMEbwi — Broadcom BCM43xx IEEE 802.11b/g wireless network driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe bwi driver provides support for Broadcom BCM43xx based PCI/CardBus network adapters.
It supports station and monitor mode operation. Only one virtual interface may be configured at any time. For more information on configuring this device, see ifconfig(8).
This driver requires firmware to be loaded before it will work. The ports/net/bwi-firmware-kmod port needs to be installed before ifconfig(8) will work.
HARDWAREThe bwi driver supports Broadcom BCM43xx based wireless devices, including:
|Apple Airport Extreme||BCM4306||PCI||b/g|
|Apple Airport Extreme||BCM4318||PCI||b/g|
|Compaq R4035 onboard||BCM4306||PCI||b/g|
|Dell Wireless 1390||BCM4311||Mini PCI||b/g|
|Dell Wireless 1470||BCM4318||Mini PCI||b/g|
|Dell Truemobile 1300 r2||BCM4306||Mini PCI||b/g|
|Dell Truemobile 1400||BCM4309||Mini PCI||b/g|
|Linksys WPC54G Ver 3||BCM4318||CardBus||b/g|
|Linksys WPC54GS Ver 2||BCM4318||CardBus||b/g|
|US Robotics 5411||BCM4318||CardBus||b/g|
The bwi driver uses the older v3 version of Broadcom's firmware. While this older firmware does support most BCM43xx parts, the bwn(4) driver works better for the newer chips it supports. You must use the bwi driver if you are using older Broadcom chipsets (BCM4301, BCM4303 and BCM4306 rev 2). The v4 version of the firmware that bwn(4) uses does not support these chips.
EXAMPLESJoin an existing BSS network (i.e., connect to an access point):
ifconfig wlan create wlandev bwi0 inet 192.168.0.20 \ netmask 0xffffff00
Join a specific BSS network with network name “
ifconfig wlan create wlandev bwi0 ssid my_net up
Join a specific BSS network with 64-bit WEP encryption:
ifconfig wlan create wlandev bwi0 ssid my_net \ wepmode on wepkey 0x1234567890 weptxkey 1 up
SEE ALSOarp(4), cardbus(4), intro(4), pci(4), wlan(4), wlan_amrr(4), ifconfig(8), wpa_supplicant(8)
HISTORYThe bwi driver first appeared in FreeBSD 8.0.
AUTHORSThe bwi driver was written for DragonFly BSD by and subsequently ported to FreeBSD.
BUGSSome card based on the BCM4306 and BCM4309 chips do not work properly on channel 1, 2 and 3.
|February 6, 2011||FreeBSD|