|ICHWD(4)||FreeBSD Kernel Interfaces Manual||ICHWD(4)|
NAMEichwd — device driver for the Intel ICH watchdog interrupt timer
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe ichwd driver provides watchdog(4) support for the watchdog interrupt timer present on all Intel ICH motherboard chipsets.
The ICH WDT counts down in ticks of approximately 0.6 seconds; the exact value depends on hardware quality and environmental factors. Supported watchdog intervals range from 2 to 63 ticks.
Note that on some ICH-based systems, the WDT may be present but disabled, either in hardware or by the BIOS. The ichwd driver attempts to detect this condition and will refuse to attach if it believes the WDT is disabled.
SEE ALSOwatchdog(4), watchdog(8), watchdogd(8), watchdog(9)
Using the Intel ICH Family Watchdog Timer (WDT), Intel Application Note AP-725, Document Number 292273-001.
HISTORYThe ichwd driver first appeared in FreeBSD 5.3.
AUTHORSThe ichwd driver was written by <firstname.lastname@example.org> of Texas A&M University and <des@FreeBSD.org>. This manual page was written by <des@FreeBSD.org>.
|August 20, 2008||FreeBSD|