|FIREWIRE(4)||FreeBSD Kernel Interfaces Manual||FIREWIRE(4)|
NAMEfirewire — IEEE1394 High-performance Serial Bus
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONFreeBSD provides machine-independent bus support and raw drivers for firewire interfaces.
The firewire driver consists of two layers: the controller and the bus layer. The controller attaches to a physical bus (like pci(4)). The firewire bus attaches to the controller. Additional drivers can be attached to the bus.
Up to 63 devices, including the host itself, can be attached to a firewire bus. The root node is dynamically assigned with a PHY device function. Also, the other firewire bus specific parameters, e.g., node ID, cycle master, isochronous resource manager and bus manager, are dynamically assigned, after bus reset is initiated. On the firewire bus, every device is identified by an EUI 64 address.
Debugging over the firewire interace is possible with the dcons(4) driver. Please see http://wiki.freebsd.org/DebugWithDcons for details on how to setup debugging with firewire.
SEE ALSOdcons(4), fwe(4), fwip(4), fwohci(4), pci(4), sbp(4), eui64(5), fwcontrol(8), kldload(8), sysctl(8)
HISTORYThe firewire driver first appeared in FreeBSD 5.0.
AUTHORSThe firewire driver was written by and for the FreeBSD project.
BUGSSee fwohci(4) for security notes.
|May 11, 2012||FreeBSD|