|DUMMYNET(4)||FreeBSD Kernel Interfaces Manual||DUMMYNET(4)|
NAMEdummynet — traffic shaper, bandwidth manager and delay emulator
DESCRIPTIONThe dummynet system facility permits the control of traffic going through the various network interfaces, by applying bandwidth and queue size limitations, implementing different scheduling and queue management policies, and emulating delays and losses.
Kernel OptionsThe following options in the kernel configuration file are related to dummynet operation:
- enable ipfirewall (required for dummynet)
- enable firewall output
- limit firewall output
- enable dummynet operation
- set the timer granularity
Generally, the following options are required:
options IPFIREWALL options DUMMYNET options HZ=1000 # strongly recommended
Additionally, one may want to increase the number of mbuf clusters (used to store network packets) according to the sum of the bandwidth-delay products and queue sizes of all configured pipes.
HISTORYThe dummynet facility was initially implemented as a testing tool for TCP congestion control by <email@example.com>, as described on ACM Computer Communication Review, Jan.97 issue. Later it has been modified to work at the IP and bridging levels, integrated with the ipfw(4) packet filter, and extended to support multiple queueing and scheduling policies.
|October 28, 2002||FreeBSD|