|CORETEMP(4)||FreeBSD Kernel Interfaces Manual||CORETEMP(4)|
NAMEcoretemp — device driver for Intel Core on-die digital thermal sensor
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe coretemp driver provides support for the on-die digital thermal sensor present in Intel Core and newer CPUs.
The coretemp driver reports each core's temperature through a sysctl node in the corresponding CPU device's sysctl tree, named dev.cpu.%d.temperature.
HISTORYThe coretemp driver first appeared in FreeBSD 7.0.
AUTHORSThe coretemp driver was written by <rpaulo@FreeBSD.org> as part of a Google Summer of Code project. This manual page was written by <des@FreeBSD.org>.
|August 23, 2007||FreeBSD|