|AXGE(4)||FreeBSD Kernel Interfaces Manual||AXGE(4)|
NAMEaxge — ASIX Electronics AX88178A/AX88179 USB Gigabit Ethernet driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe axge driver provides support for USB Gigabit Ethernet adapters based on the ASIX Electronics AX88179 USB 3.0 and AX88178A USB 2.0 chipsets.
The AX88179 and AX88178A contain a 10/100/1000 Ethernet MAC with a GMII interface for interfacing with the Gigabit Ethernet PHY.
These devices will operate with both USB 1.x and USB 2.0 controllers, and the AX88179 will operate with USB 3.0 controllers. Packets are received and transmitted over separate USB bulk transfer endpoints.
The axge driver supports the following media types:
- Enable autoselection of the media type and options. The user can manually override the autoselected mode by adding media options to rc.conf(5).
- Set 10Mbps operation. The ifconfig(8) mediaopt option can also be used to select either full-duplex or half-duplex modes.
- Set 100Mbps (Fast Ethernet) operation. The ifconfig(8) mediaopt option can also be used to select either full-duplex or half-duplex modes.
- Set 1000Mbps (Gigabit Ethernet) operation (AX88178 only). The ifconfig(8) mediaopt option can also be used to select either full-duplex or half-duplex modes.
The axge driver supports the following media options:
- Force full duplex operation.
- Force half duplex operation.
For more information on configuring this device, see ifconfig(8).
HISTORYThe axge device driver first appeared in FreeBSD 10.1.
AUTHORSThe axge driver was written by <kevlo@FreeBSD.org> and <lwhsu@FreeBSD.org>. This manual page was adapted by <markj@FreeBSD.org> from the axe(4) manual page.
|November 22, 2013||FreeBSD|