|ATKBDC(4)||FreeBSD Kernel Interfaces Manual||ATKBDC(4)|
NAMEatkbdc — the AT keyboard controller interface
DESCRIPTIONThe keyboard controller atkbdc provides I/O services for the AT keyboard and PS/2 mouse style pointing devices. This controller is required for the keyboard driver atkbd and the PS/2 pointing device driver psm.
There can be only one atkbdc device configured in the system.
Kernel Configuration OptionsThe following kernel configuration options can be used to control the atkbdc driver. They may be set in the kernel configuration file (see config(8)).
- KBD_RESETDELAY=X, KBD_MAXWAIT=Y
- The keyboard driver atkbd and the pointing device driver psm may ask the atkbdc driver to reset these devices during the boot process. It sometimes takes a long time before these devices respond to the reset command. These options control how long the atkbdc driver should wait before eventually giving up -- the driver will wait X * Y msecs at most. If the drivers seem unable to detect devices, you may want to increase these values. The default values are 200 msec for X and 5 for Y.
- Sets the debug level to N. The default value is zero, which suppresses all debugging output.
HISTORYThe atkbdc driver first appeared in FreeBSD 3.1. It is based on the kbdio module in FreeBSD 2.2.
AUTHORSThe kbdio module, the atkbdc driver and this manual page were written by <yokota@FreeBSD.org>.
|February 9, 1999||FreeBSD|