|ARCMSR(4)||FreeBSD Kernel Interfaces Manual||ARCMSR(4)|
NAMEarcmsr — Areca RAID Controller driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe arcmsr driver provides support for the Areca ARC-11xx, ARC-12xx, ARC-13xx, ARC-16xx and ARC-18xx series of SAS and SATA RAID controllers. These controllers feature RAID-0, 1, 3, 5, 6, and 10 and JBOD acceleration for up to 16 SATA drives. RAID level and stripe level migration, online capacity expansion, hot insertion/removal, automatic failover and rebuild, and SMART are also supported. Access to the arrays is provided via the SCSI CAM /dev/da? device nodes. A management interface is also present via the /dev/arcmsr? device node. Management tools for i386 and amd64 are available from Areca.
HARDWAREThe arcmsr driver supports the following cards:
- Array block device
- Management interface
HISTORYThe arcmsr driver first appeared in FreeBSD 5.4.
AUTHORSThe driver was written by <firstname.lastname@example.org>.
BUGSThe driver has been tested on i386 and amd64. It likely requires additional work to function on big-endian architectures.
|February 27, 2013||FreeBSD|