EN JA
APIC(4)
APIC(4) FreeBSD Kernel Interfaces Manual APIC(4)

NAME

apicAdvanced Programmable Interrupt Controller (APIC) driver

SYNOPSIS

This driver is a mandatory part of amd64 kernel. To compile this driver into i386 or pc98 kernel, place the following line in your kernel configuration file:

device apic

The following tunable is settable from the loader(8):

hint.apic. X .clock
controls event timers functionality support. Setting to 0, disables it. Default value is 1.
hint.apic. X .disabled
Set this to 1 to disable APIC support, falling back to the legacy PIC.

DESCRIPTION

There are two components in the Intel APIC system, the local APIC (LAPIC) and the I/O APIC. There is one local APIC in each CPU in the system. There is typically one I/O APIC for each peripheral bus in the system.

Local APICs manage all external interrupts for a specific processor. In addition, they are able to accept and generate inter-processor interrupts (IPIs).

I/O APICs contain a redirection table, which is used to route the interrupts they receive from peripheral buses to one or more local APICs.

Each local APIC includes one 32-bit programmable timer. This driver uses them to supply kernel with one event timer named "LAPIC". Event timer provided by the driver supports both one-shot an periodic modes. Because of local APIC nature it is per-CPU. The timer frequency is not reported by the platform and so automatically measured by the driver on the first use. Depending on CPU model this timer may stop in C3 and deeper CPU sleep states. Driver automatically adjusts event timer priority and reports it to prevent entering dangerous sleep states when it is used.

December 20, 2011 FreeBSD