|ACPI_TOSHIBA(4)||FreeBSD Kernel Interfaces Manual||ACPI_TOSHIBA(4)|
NAMEacpi_toshiba — Toshiba HCI interface
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONHCI is Toshiba's Hardware Control Interface which is somewhat uniform across their models. The acpi_toshiba driver allows the user to manipulate HCI-controlled hardware using a number of sysctl(8) variables.
SYSCTL VARIABLESThe following sysctls are currently implemented:
Causes active cooling to be forcibly enabled (‘
1’) or disabled (‘
0’) regardless of the current temperature.
Sets the active display to use according to a bitwise OR of the following:
- No display
Only some systems (i.e., the Libretto L5) support video switching via this hardware-specific driver. Use the acpi_video(4) driver for generic video output support.
- Makes the LCD backlight brighter or dimmer (higher values are brighter).
- Turns the LCD backlight on and off.
- Sets the CPU speed to the specified speed. This provides functionality similar to the hw.acpi.cpu.throttle_state variable. Higher sysctl values mean lower CPU speeds.
Defaults for these variables can be set in sysctl.conf(5), which is parsed at boot-time.
LOADER TUNABLESThe hw.acpi.toshiba.enable_fn_keys tunable enables or disables the function keys on the keyboard. Function keys are enabled by default.
HISTORYThe acpi_toshiba driver first appeared in FreeBSD 5.1.
AUTHORSThe acpi_toshiba driver was written by <firstname.lastname@example.org>. This manual page was written by <philip@FreeBSD.org>.
|February 8, 2010||FreeBSD|