|ACPI_SONY(4)||FreeBSD Kernel Interfaces Manual||ACPI_SONY(4)|
NAMEacpi_sony — ACPI notebook controller driver for Sony laptops
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe acpi_sony driver provides support for the notebook controller in Sony laptops. Note that not all features will work on all laptop models.
SYSCTLSThe following sysctl nodes are currently implemented:
- Current brightness level of the display.
- Default brightness level of the display (survives reboot).
- Current contrast level of the display.
- Enable or disable the Bass Gain feature.
- Turns the CD power on or off.
- Turns the audio power on or off.
- Turns the wired network interface power on or off.
HISTORYThe acpi_sony driver first appeared in FreeBSD 6.0.
AUTHORSThe acpi_sony driver was written by <takawata@FreeBSD.org>.
|February 8, 2010||FreeBSD|