|ACPI_ASUS_WMI(4)||FreeBSD Kernel Interfaces Manual||ACPI_ASUS_WMI(4)|
NAMEacpi_asus_wmi — Asus Laptop WMI Extras
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe acpi_asus_wmi driver provides support for the extra WMI-controlled gadgets, such as hotkeys and leds, found on Asus laptops. It allows one to use the sysctl(8) interface to manipulate the brightness of the LCD panel and keyboard backlight, power on/off different internal components, such as WiFi, Bluetooth, camera, cardreader, etc, read some sensors. Hotkey events are passed to devd(8) for easy handling in userspace with the default configuration in /etc/devd/asus.conf. Some hotkey events, such as keyboard backlight and touchpad control, are handled inside the driver.
SYSCTL VARIABLESThe following sysctls are currently implemented:
- Specifies whether driver should handle some harwdare keys, such as keyboard backlight, internally.
Number of other variables under the same sysctl branch are model-specific.
Defaults for these variables can be set in sysctl.conf(5), which is parsed at boot-time.
HISTORYThe acpi_asus_wmi driver first appeared in FreeBSD 10.0.
|July 2, 2012||FreeBSD|