|ACPI_ASUS(4)||FreeBSD Kernel Interfaces Manual||ACPI_ASUS(4)|
NAMEacpi_asus — Asus Laptop Extras
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe acpi_asus driver provides support for the extra ACPI-controlled gadgets, such as hotkeys and leds, found on recent Asus (and Medion) laptops. It allows one to use the sysctl(8) interface to manipulate the brightness of the LCD panel and the display output state. Hotkey events are passed to devd(8) for easy handling in userspace with the default configuration in /etc/devd/asus.conf.
Currently, the following Asus laptops are fully supported:
- Eee PC
Additionally, acpi_asus also supports the Asus-compatible ATK0100 interface found in Samsung P30/P35 laptops.
SYSCTL VARIABLESThe following sysctls are currently implemented:
- Makes the LCD backlight brighter or dimmer (higher values are brighter).
- Turns the LCD backlight on or off.
Sets the active display to use according to a bitwise OR of the following:
- No display
Some models also support video switching via the generic acpi_video(4) driver. Most models do not, however.
Defaults for these variables can be set in sysctl.conf(5), which is parsed at boot-time.
SEE ALSOacpi(4), acpi_asus_wmi(4), acpi_video(4), sysctl.conf(5), sysctl(8)
The acpi4asus Project, http://sourceforge.net/projects/acpi4asus/.
HISTORYThe acpi_asus driver first appeared in FreeBSD 5.3.
AUTHORSThe acpi_asus driver and this manual page were written by <philip@FreeBSD.org>.
Inspiration came from the acpi4asus project started by which maintains a driver implementing this functionality in the Linux kernel.
|February 8, 2010||FreeBSD|