|AACRAID(4)||FreeBSD Kernel Interfaces Manual||AACRAID(4)|
NAMEaacraid — Adaptec AACRAID Controller driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configuration file:
To compile in debugging code:
Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5):
DESCRIPTIONThe aacraid driver provides support for the Adaptec by PMC RAID controllers, including Series 6/7/8 and upcoming families.
The RAID containers are handled via the aacraidp0 bus. The physical buses are represented by the aacraidp? devices (beginning with aacraidp1). These devices enable the SCSI pass-thru interface and allows devices connected to the card such as CD-ROMs to be available via the CAM scsi(4) subsystem. Note that not all cards allow this interface to be enabled.
The /dev/aacraid? device nodes provide access to the management interface of the controller. One node exists per installed card. If the kernel is compiled with the COMPAT_LINUX option, or the aacraid_linux.ko and linux.ko modules are loaded, the Linux-compatible ioctl(2) interface for the management device will be enabled and will allow Linux-based management applications to control the card.
HARDWAREControllers supported by the aacraid driver include:
- Adaptec ASR-6405(T|E)
- Adaptec ASR-6445
- Adaptec ASR-6805(T|E|Q|TQ)
- Adaptec ASR-7085
- Adaptec ASR-7805(Q)
- Adaptec ASR-70165
- Adaptec ASR-71605(E|Q)
- Adaptec ASR-71685
- Adaptec ASR-72405
- Adaptec Series 8 cards
- aacraid management interface
DIAGNOSTICSCompiling with AACRAID_DEBUG set to a number between 0 and 3 will enable increasingly verbose debug messages.
The adapter can send status and alert messages asynchronously to the driver. These messages are printed on the system console, and are also queued for retrieval by a management application.
AUTHORS<achim@FreeBSD.org> <emaste@FreeBSD.org> <scottl@FreeBSD.org>
BUGSThe controller is not actually paused on suspend/resume.
|April 9, 2013||FreeBSD|